Sunday, November 11, 2012

Installing Demos on Windows 8

For demos packaged in DemoMate builds previous to 1.5.1137, users might encounter installation issues on Windows 8 machines, where the installer does not progress past the "Installing DemoMate prerequisites" task.

This occurs because DemoMate is currently built using features of the .NET 3.0 Framework, which some installations of Windows 8 might not have installed by default. To configure your machine to run DemoMate, please follow these instructions:

1. Press the Start button, and do a search for “Turn Windows features on”.

2. Select the Settings option in the right-hand search results.

3. Click or tap the Turn Windows features on or off item:

4. In the Windows Feature dialog box, place a check next to .NET Framework 3.5 and then click OK.

5. The .NET Framework 3.5 will now install on your machine. Once the installation has completed, you can run the DemoMate installer on your machine.

For demos packaged with Build 1.5.1137 or later, this issue will not occur, as the installer has been updated to correctly install the .NET Framework 3.5 on Windows 8. If you plan on distributing demos to a team that is using Windows 8, it is recommended that you take a minute and repackage the demos in Build 1.5.1137 or later, so your team has the best experience deploying the demos.

No comments: